Questions & Answers

elk version of pnda

0 votes
asked Sep 7, 2017 by Saqib Arfeen (560 points)
Hello
I would like to know that why pnda has old version of elk stack.My pnda deployment (v3.5) has these versions of elk whereas current version is 5.4:-
logstash 5.0.2
elasticsearch 1.5.0
kibana 4.1.6

1 Answer

+1 vote
answered Sep 7, 2017 by James Clarke (1,710 points)
Hi, there is no particular reason, it was originally implemented at 1.5.0 when that was the current release. To take advantage of newer features we have upped Logstash and Kibana, and now on the develop branch it uses logstash 5.2.2 and Kibana 4.1.6. We never had any need to use a newer elasticsearch. Are there any issues you are having with it?

Cheers,

James
commented Sep 7, 2017 by Saqib Arfeen (560 points)
thanks for response
yes,I was missing some features that are present in kibana5 , like filter for field present and edit filter in ui , so I was wondering it.
screenshot: https://ibb.co/nr5bpF
commented Sep 10, 2017 by trsmith2 (3,440 points)
We would be happy to review a pull request if you'd like to work on this.
...